in

Rose Gardening Community

A RoseMagazine.com Sponsored Community

 


Missing Flowers!

Last post 05-14-2009 10:49 AM by wolfdrum. 6 replies.
Page 1 of 1 (7 items)
Sort Posts: Previous Next
  • 01-02-2007 9:08 PM

    Missing Flowers!

    I have six climbers and among them are two rather new (a year and half old) climbers (one red and one pink) that are growing tremendously, they are covering the wall of 2x5 meters wall completely since a couple of months WITHOUT giving any flower buds! They did give some flowers in the spring time, but after that, no buds at all anymore, they keep on growing, growing, without no flower... Other climbers are blooming regularly. Is there anything I can do to help them produce flower buds? The instruction says I don't have to cut the branches, but they look very messy. May I cut them? If yes, when?
  • 01-02-2007 9:08 PM In reply to

    Re: Missing Flowers!

    I've got the same problem. Tons of new growth, but no flowers. Any suggestions?
  • 01-02-2007 9:09 PM In reply to

    Re: Missing Flowers!

    It could be that these climbers that you have are the once blooming kind that bloom in the early summer and then not again. climbers can be pruned in the dormant season by taking out old and woody stems and shortening the lateral stems back by a few inches. Climbers also produce more flowers if you tie the branches horizontally onto a trellis or fence and then also tie the laterals that will be produced all up and down the main stem. That way you'll get tons of little stems off of the main stems, thereby creating more blooms.
  • 01-02-2007 9:09 PM In reply to

    Re: Missing Flowers!

    I too have climbers that have lots of leaves and branches but have never bloomed. Plants on either side bloom continuously. Do I just have to replace the plant?
  • 01-02-2007 9:09 PM In reply to

    Re: Missing Flowers!

    I planted 4 New Dawns in the same bed on same trellis early this year. Two gave me tremendous growth and no blooms. The two others have given me fair growth and good blooms. I cannot determine any significant environmental differences. Anyone have either an explanation or a suggestion to stimulate the blooms? I am satisfied with the slower growth.
  • 05-05-2009 12:41 PM In reply to

    Re: Missing Flowers!

     

    I also planted a NEW DAWN climber last year and it grew well last year and this spring but it has NEVER produced any flowers. The canes and leaves are  a beautiful healthy and shiny green. I love the foliage. It is on a trellis on the south side of the house where it gets plenty of light.  I was told to put some fertilizer one a month, but last year I think that I applied fertilizer two times all summer. 

    I would really like to know what to do!  HELP!  should I tear out this rose bush and get another one? I hate to do that. It is so beautiful otherwise.  I should also say that they are not 7 leaf blind shoots but they are all five leaf.

     Thanks

  • 05-14-2009 10:49 AM In reply to

    Re: Missing Flowers!

    Fran1973!  Have you started feeding yet?  How's your soil/drainage?  Have you tried Epsom salts? What zone/state are you?

    Make sure you giving it enough sun (6 hours minimum), water (must drain well), and insect/disease control....

    Get back to me on this and we'll nip this in the bud!

    Wink

Page 1 of 1 (7 items)

Advertise With Us
Your Text Ad Goes Here
Let our Community know of your products and services. Your Ad dollars are well spent at RoseMagazine.com
http://www.rosemagazine.com/form/advertise.asp


Copyright © 2015 Rose Magazine Inc. All rights reserved.
Powered by Community Server (Non-Commercial Edition), by Telligent Systems